mPrinter
Unofficial forum about mPrinter.

Home » Using mPrinter » Troubleshooting » Reset
Reset [message #157] Wed, 15 July 2015 20:04 Go to next message
AnMartini is currently offline  AnMartini
Messages: 13
Registered: September 2013
Location: Bologna, Italy
Junior Member

Hi everyone.

I'm writing here again because while trying to test the printer in different ways I found an unexpected problem. I had the mPrinter connected via WiFi and I was printing test pages via CUPS trying to share the printer over the network. Few minutes later the printer appeared as disconnected. I switched it off and on but nothing. The info print (2 presses on the button) said that it was operating as "Idle". So I tried to reset it (5 presses on the button) and I connected my PC to the MPRINTER wifi (yes, now it appears as MPRINTER and not MPRINTER_XXXXXX).
The problem is that as I try to visit 169.254.1.1 I get this message:
404: File not found
Use [http://169.254.1.1/mpfsupload](MPFS Upload) to program web pages

I really do not know what to do... It seems that the web interface is gone, while the printer is still working. Does someone find a way to get the file to upload with MPFS Upload to restore the interface?
I can't understand why resetting the mPrinter has no effects...


Andrea
Re: Reset [message #158 is a reply to message #157] Thu, 16 July 2015 11:33 Go to previous messageGo to next message
badger is currently offline  badger
Messages: 71
Registered: September 2013
Location: Prague, CZ
Member
Administrator
Hi AnMartini,
my printer quite often stops responding and only powering it off and on again several times helps.
But what you describe.. I'm not sure what went wrong.. Generally, I'd say try to reset to factory once again and maybe after setting it once again (I know, annoying) it will work. The code in the printer is quite.. crappy and tend to show "unexpected bahavior" quite often in almost any situation.
I'd write some firmware myself but I was unable to get any HW documentation from Andy and I didn't want to spend that much time by reverse engineering everything.


Re: Reset [message #159 is a reply to message #158] Thu, 16 July 2015 21:12 Go to previous messageGo to next message
AnMartini is currently offline  AnMartini
Messages: 13
Registered: September 2013
Location: Bologna, Italy
Junior Member

Hi badger,
thank you as always for your reply! I've tried several time the reset process (5 presses) with no success... I put the mPrinter away and I'll try again in some days: I want to try to discharge the battery and recharge it to see if something change. I'll update if I find something new.
I'll write to Andy, maybe he can send me the image to upload to restore the web interface... but i doubt it!


Andrea
Re: Reset [message #160 is a reply to message #159] Fri, 17 July 2015 11:07 Go to previous message
badger is currently offline  badger
Messages: 71
Registered: September 2013
Location: Prague, CZ
Member
Administrator
I'd say remove the battery for a while to leave everything discharge. Seems like somthing bad survives for quite long time even if there is no power at all.
It's not good to discharge the battery too deep. However it has some overdischarge protection circuit.


Previous Topic: missing pieces of image
Goto Forum:
  


Current Time: Mon Jul 24 12:35:01 CEST 2017

Total time taken to generate the page: 0.05363 seconds